Nomar记录一段历史
为什么我的 3D 打印机在我设置的流速非常低时过度挤压

您好,我正在使用 Cura 对我的打印件进行切片,尽管将流速调至最小值 5%,但我的打印件仍然严重过度挤出。

我已经使用 Pronterface 完美地校准了挤出机步进机,所以我不明白为什么会发生这种情况。我还计算了挤出一定长度所需的时间,并将其与要挤出的时间长度进行比较,结果完全相同。因此,我得出结论,步进器的校准没有问题。

所以,我认为Cura上的设置有问题。最初,我的流速为 100%,这真的非常非常糟糕。然后我尽可能地把它调小,打印效果更好,但仍然存在过度挤压。我不能再降下去了。

我无法弄清楚问题可能是什么,正如您想象的那样,这非常非常令人沮丧。

这是打印配置文件: 打印配置文件的屏幕截图

编辑- 一些额外的信息

所以打印机没有任何型号,因为它是自制的光驱3D打印机。它与 Curiosity3D 打印机有许多相似之处,因此如果您想了解有关其工作原理的更多信息,那么他们的网站将非常有价值。 链接

挤出机是鲍登式的。它使用便宜的 e3d hotend Link to amazon和 RepRap extruder kit 作为电机Link to amazon

以下是机器设置:

机器设置截图

这是两张失败的印刷品的照片。左边是一个G,右边是一个心形。 两张失败印刷品的照片

这就是 G 的样子:

接口G

编辑 2 - 更多信息

所以这是我之前为我的 3D 打印机修改的 configuration.h 文件的链接。 Dropbox 链接

我使用的灯丝也是“Robox PLA SmartReel Cornflower Blue” 链接

任何帮助将不胜感激。

210对PLA来说有点多,我建议去185或195。你有你得到的结果的图片吗?你说它在挤压下,但通过图片我们可以更好地确定它是否被挤压。
也许你没有启用微步进(所以挤出,例如 16 或 32 次太快了)
@Valmond 我目前将所有三个跳线都插入到斜坡板挤出机步进驱动器区域的引脚上。我认为这提供了 64x 微步进。如果我这样做,是否有我也改变的设置?
不,如果情况相反,那么也许,但为此你似乎很好。现在有了您添加的打印机信息,您使用什么固件?如果是 Marlin(就像 Curiosity3D 那样),那么检查挤出机配置!您有直接驱动(如 Curiosity3D ),许多使用减速驱动,这可能是您的问题。你自己刷过吗?
1) 请从 Marlin 固件发布 Configuration.h 2) EEProm 是否已激活?
@Valmond 好的,所以我现在在 Dropbox 上添加了一个指向配置的链接。我不知道 EEProm 是做什么的,但似乎“EEProm_settings”已被注释掉。似乎我的电机是直接的,在查看配置后,如果我有直接挤出机,我需要将“false”更改为“true”,但我没有这样做。我现在已经改变了这一点,但问题仍然存在。
乍一看(第 527 行)值似乎合理(如果,如您的 sceencap 所述,您的可打印区域为 37 毫米宽等)。印刷品的尺寸是否大致正确?如果是这样,请移除鲍登管并让您的控制器软件通过挤出机移动 100 毫米长丝(标记前后 + 测量),它关闭了多少? -> 正确的第 527 行(第四个值)+ 编译 + 闪存 -> 重做测试直到确定。编辑:由于 eeprom 似乎已禁用,也许您没有使用 5% 进给率覆盖值?请告诉。
@Valmond 所以,它似乎以正确的尺寸打印。我之前也校准了挤出机电机的每毫米步数。我不知道如何检查 5% 的流速是否是最重要的值。它意味着要覆盖哪些值?
让我们[在聊天中继续讨论](http://chat.stackexchange.com/rooms/70507/discussion-between-joe-clinton-and-valmond)。

4个回答

首先:您能告诉我们,您使用的打印机是什么类型的,材料是什么?请给我们一些印刷品的图片。此外,挤出机设置的类型也是相关的。它是 Bowden 挤出机还是直接驱动挤出机?

对于像带有 PLA 的 Prusa 风格打印机这样的 FDM 机器:

  • 5% 的流量是完全错误的,通常 PLA 应该在 90% 和 105% 之间完美运行。问题出在其他地方,而不是流量设置,温度也不是有问题的。
    • 对于大多数 PLA 来说,185 °C 和 210 °C 之间的温度应该没问题
    • 您是否在 Cura 中正确设置了打印机(首选项 -> 打印机 -> 机器设置)?材料直径、喷嘴尺寸和 G-Code 风味是否正确?

如果您给我们提供更多信息,我将很高兴解决这个问题。

正如我从您的图片和附加信息中看到的,您遇到了多个问题。看起来您的打印方式太快了(降低所有电机的加速度和加加速度)。正如其他人提到的:检查您的电机是否没有跳过步骤。也许您的 Z 高度也没有很好地校准。

您的打印机是使用低功率步进电机的临时构建,这一事实往往表明问题出在您的硬件和/或固件中。很难为此类打印机提供建议,因为大多数 3D 打印机所有者对它们的体验为零。

您的问题的可能原因很明显:

  • 检查步进电机是否没有跳动,以及每毫米的步数是否正确。
  • 检查您的挤出机没有跳动,并且每毫米的步数正确。
  • 检查您的固件是否与挤出机速度正确匹配耗材流量。
  • 检查您的固件配置是否正确。您如何为临时构建执行此操作在很大程度上取决于您。

我建议的一件事是您减少加加速度和加速度值,因为它们看起来太高了。

到目前为止,您已经完成了这样的构建,但您可能不得不问自己,继续您的项目是否有任何收获。

看看张贴的图片,电机显然在跳动。他的问题不是跳过(在这篇文章中),而是挤出机电机挤出太快。

我想要么你的热端离第一层太远(所以看起来像挤压不足),然后错误的层高/错误的 z 配置,所以层太小,使塑料堆积(似乎过度挤压)。最终,如果 Z-Driver 跳过步骤,它可能看起来相同(打印机多次尝试打印同一层)。

驱动程序中也有一些跳过,因为您的层没有正确地相互叠加,请检查您是否可以“提高”驱动程序中的安培数,或者减慢一切(速度、加速度和混蛋)直到它在不跳过的情况下工作.

我最好的选择是,您应该 1) 首先让您的驱动程序停止跳过,2) 然后使用 configuration.h(第 527 行)仔细校准您的机器,以便 x、y、z、e 至少都大致没问题。

然后开始打印:-)

附带说明一下,您还可以激活 EEPROM 并使用 GCode 存储新值,这主要是一件“方便”的事情,因为您不需要在每次更改时重新编译和刷新您的电路板,所以也许以后一切都好开始工作正常。

HTH

我不久前解决了这个问题,但我意识到其他人可能会看到这一点。我不确定是什么修复了它。当它突然再次开始工作时,我正在干预 ee-prom。我怀疑以某种方式在 ee-prom 上存储了每毫米值的不同步长,所以无论我做了什么改变它(在固件中)它都没有区别。然后我要么更改 ee-prom 中的设置,要么禁用它。我真的想不起来了。

当它开始工作时,它看起来好像什么都没有挤出,因为 5% 的挤出率真的很低!

随机文章