Nomar记录一段历史
Slic3er 抛出“AMF 解析需要 XML::SAX”

当我尝试打开准备好的.amf盘子并打印一些项目时,Prusa 的 Slic3er 版本会抛出以下错误:

AMF 解析需要 XML::SAX

切片机版本是为 Prusa 的 i3 MK2 1.75 打印机分发的 1.30。

您最终找到了解决方案吗?我假设您已经尝试重新安装和/或更新 Slic3r,对吗? +1 不得不在此列表中提及 XML,这是我没想到的....

1个回答

slic3r 软件是用 Perl 编写的,Perl 是一种可以使用本地库进行扩展的编程语言。 XML::SAX 就是这样一个库。 CPAN 是一种工具,可用于从 CPAN 存储库(综合 Perl 存档网络,我相信)中检索库。

我使用 CPAN 是我很少使用的东西,所以我试图在这里列出这些步骤会造成伤害。毫无疑问,更好的答案是在 stackexchange 上。尽管如此,这些可能会有所帮助:

从您的命令行,启动 Perl 运行 CPAN 模块,并调用 CPAN shell(您的输入以粗体显示):

> perl -MCPAN -e shell
cpan>安装 XML::SAX
cpan> ...几行输出...
完成!
XML::SAX 是最新的 (0.99)。
cpan>退出
>

完成后,再次尝试使用 slic3r。

随机文章